Monday, November 17, 2008

WiiDoom 0.4 HBC bug

This issue is only when launching via HBC. I just blew away my WiiDoom install on my SD card, and copied only the 0.4 installation files (plus doom.wad). It works just fine.

I'm not sure what's different about the HBC method. I'm using absolute file paths, so it shouldn't be an issue. If anyone wants to work with me on it, I'd appreciate it. I don't use the HBC, so if I come up with anything, I'll need a few testers. If anyone wants to test, lemme know.

Until then, 0.4 is being re-released, for those that are using the Twilight Hack launch method.

11 comments:

dr said...

ready to test with HBC. bring it.

vin said...

I don't exactly know what it entails, but I'm willing to help!

I have some programming exp.

Steve Corey said...

My first thought is to create a prboom folder where the boot.dol is for HBC users (/apps/WiiDoom/) and copy the fonts and images folders to there (along with the corresponding files).

Anyone want to give that a shot and report findings?

vin said...

I'll give it a shot in a couple of hours(when I'm out of class).

I don't exactly now how though, so I may not be the man for the job. Is all of the in the prboom folder? or do I need to compile them from the source code?

Steve Corey said...

No, you don't have to compile anything. Here's a simpler way of testing my theory:

Extract the prboom directory from the zip file into:

(sdcard drive):\apps\wiidoom\

So you should now have:

(sdcard drive):\apps\wiidoom\prboom

vin said...
This comment has been removed by the author.
vin said...

ALRIGHT! IT WORKS!! This is what I have on my SD card:
in folder X:\apps\WiiDoom\:
boot.dol
CHANGES.WRI
copying
icon.png
meta.xml
WiiDoom.wri
\prboom\ (file, contents as follows:)


\fonts\
\images\
\pwads\
prboom.wad


that's it,
booted it from the HBC.

I still have the folder X:\prboom\ with my wads and saves. (do I need to put any pwads in the pwad folder?

Steve Corey said...

Vin, can you email me directly so I can send you an updated zip file to test?

Steve Corey said...

You only need PWADs in the "real" prboom\pwads directory (off the root). It still runs fine if there's no PWAD files, though.

Steve Corey said...

If anyone else wants to test this, email me (within an hour).

suloku said...

10.19 12:36:44: Couldn't find PRBOOM/FONTS/DOOM.TTF to get its length
10.19 12:36:44: Couldn't find PRBOOM/FONTS/DOOM.TTF to get its length
10.19 12:36:44: Couldn't find PRBOOM/FONTS/DOOM.TTF to get its length
10.19 12:36:44: Couldn't find PRBOOM/FONTS/DOOM.TTF to get its length
10.19 12:36:44: Couldn't find PRBOOM/IMAGES/DOOM.BMP to get its length
10.19 12:48:21: Couldn't find PRBOOM/FONTS/DOOM.TTF to get its length
10.19 12:48:21: Couldn't find PRBOOM/FONTS/DOOM.TTF to get its length
10.19 12:48:21: Couldn't find PRBOOM/FONTS/DOOM.TTF to get its length
10.19 12:48:21: Couldn't find PRBOOM/FONTS/DOOM.TTF to get its length
10.19 12:48:21: Couldn't find PRBOOM/IMAGES/DOOM.BMP to get its length
10.19 12:49:39: Couldn't find PRBOOM/FONTS/DOOM.TTF to get its length
10.19 12:49:39: Couldn't find PRBOOM/FONTS/DOOM.TTF to get its length
10.19 12:49:39: Couldn't find PRBOOM/FONTS/DOOM.TTF to get its length
10.19 12:49:39: Couldn't find PRBOOM/FONTS/DOOM.TTF to get its length
10.19 12:49:39: Couldn't find PRBOOM/IMAGES/DOOM.BMP to get its length


This is the error at the wiidom dir. That's what it outputs before the code dump.

As you thought, having WiiDoom/prboom/fonts and WiiDoom/prboom/images solves the problem for now.